| HOMEPAGE = "https://gbmc.googlesource.com/pldm" |
| LICENSE = "Apache-2.0" |
| LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327" |
| SRC_URI = "git://gbmc.googlesource.com/pldm;branch=google-dev;protocol=https" |
| SRCREV = "9b9ccac8c2b0bd9730592283fda7a27134ee5058" |
| |
| SUMMARY = "PLDM Stack (Google Fork)" |
| DESCRIPTION = "Implementation of the PLDM specifications" |
| DEPENDS += "function2" |
| DEPENDS += "systemd" |
| DEPENDS += "sdeventplus" |
| DEPENDS += "phosphor-dbus-interfaces" |
| DEPENDS += "nlohmann-json" |
| DEPENDS += "cli11" |
| DEPENDS += "libpldm" |
| DEPENDS += "phosphor-logging" |
| PV = "1.0+git${SRCPV}" |
| PR = "r1" |
| |
| S = "${WORKDIR}/git" |
| SYSTEMD_SERVICE:${PN} += "pldmd.service" |
| |
| inherit meson pkgconfig |
| inherit systemd |
| |
| PACKAGECONFIG[transport-af-mctp] = "-Dtransport-implementation=af-mctp" |
| PACKAGECONFIG ??= " transport-af-mctp" |
| |
| EXTRA_OEMESON = " \ |
| -Dtests=disabled \ |
| -Doem-ibm=disabled \ |
| -Dsoftoff=disabled \ |
| -Dampere=disabled \ |
| -Dmetrics-dump-period=600 \ |
| " |
| |
| do_install:append () { |
| rm -rf ${D}/usr/share |
| } |